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LR, LTR & Development Versions

QGIS 3.4

Madeira

e Latestrelease (LR) version
o eslaultima actualizaciéon estable: 3.10 A Coruina
o perfecta para nuestro trabajo diario
o establey con las ultimas novedades

e Long Term Release (LTR) version
o ultima versién con largo recorrido: 3.4 Madeira
o [ultima versién con largo recorrido antigua: 2.18.x Las Palmas]

o orientadaaequipos de produccién

e Development (Dev) version
o eslaversionendesarrollo: 3.11 Master
o solo paradesarrolladores
o estabilidad NO garantizada
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"\GI

Python 3 + Qt5 Visual Changelog

Cambios de 2.18 a 3.x

Reescritura de buena parte del programa
— mayor estabilidad

24 Days of QGIS 3.0 Features | #24daysofggis @northroadgeo

#agis AND @msevillaOO0 | comparativa con 2.18 |

Editing Tools

Q QGIS 3.0 Shortcuts ROAD | o

y Toggle Editing Layer > Toggle Editing

E Save Edits Layer > Current Edits > Save
Project Management 9l - v
D e = 7 e °n Add Feature (point) Edit > Add Feature Ctrl +

ew Project roject > New trl +
ey \.ﬁ: Add Feature (line) Edit > Add Feature Ctrl+.
L Open Project Project > Open Ctrl+ 0 b
=] 2 Add Feature (polygon) Edit > Add Feature Ctrl +
Save Project Project > Save Ctrl+S
Move Feature Edit > Move Feature

ay Save Project As Project > Save As Ctrl + Shift+ S 1
-~ Node Tool Edit > Node Tool
[_ h New Print Layout Project > New Print Layout Ctrl +P /.5_(

-~
£ m’] Delete Features Edit > Delete Selected Del
Layer Management

P Reshape Feature Edit > Reshape Features
’ Add Layer Layer > Data Source Manager Ctrl + L

= % Split Features Edit > Split Features

Q_’ Create New GeoPackage Layer > Create > New GeoPackage Layer Ctrl + Shift+ N

(. Merge Features Edit > Merge Selected Features
v° Create New Vector Layer Layer > Create > New Shapefile Layer

Enable Snapping S
ﬂ Remove Selected L aver Laver > Remove laver/Groun Ctrl+ D


https://qgis.org/en/site/forusers/visualchangelog30/index.html
https://north-road.com/2017/12/24/24-days-of-qgis-3-0-features/
https://twitter.com/search?f=tweets&q=%2324daysofqgis%20%40northroadgeo&src=typd
https://twitter.com/search?f=tweets&vertical=default&q=%23qgis%20AND%20%40msevilla00&src=typd
https://translate.google.com/translate?depth=1&hl=en&rurl=translate.google.com&sl=sv&sp=nmt4&tl=en&u=https://geosupportsystem.wordpress.com/2018/03/20/qgis-2-18-vs-qgis-3-0/&xid=17259,1500008,15700023,15700105,15700124,15700149,15700168,15700173,15700186,15700201
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Instalacion del programa

QGIS incluye GRASS

descarga libre y gratuita de los archivos
instrucciones en laweb de QGIS
http://agis.org/.../download.html

Windows

a) archivo uUnico ejecutable

b)

Linux. a través de la carga de repositorio de archivos

Mac. siguiendo instrucciones e instalacion binario de QGIS
Android: App disponible en Google Play

Otros: Portable GIS (QGIS version 3.4) o OSGeo Live

> > M "4,

2



http://qgis.org/en/site/forusers/download.html
https://play.google.com/store/apps/details?id=org.qgis.qgis
https://portablegis.xyz/
http://live.osgeo.org/
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O sin instalar... ;ccomo?

e Portable-GIS - aplicaciones GIS portatiles
o http://www.archaeogeek.com/portable-gis.html
o Desktop GIS packages: QGIS (with GRASS plugin), GDAL and OGR toolkit,
Apache2 and PHP, PostgreSQL/PostGIS, Mapserver, OpenLayers, Python
with GDAL libraries and Psycopg2, Geoserver & utilities

o OSGeo Live ;
, e
http://live.osgeo.org/ ——r

Glients

todo lo que necesitas enuna m o
distro Live de GNU/Linux N ki

o Lubuntu+ FOSS4G tools 2 %
Desktop & Server GIS
ISO / Maquina Virtual

. & Browser Clients
» |8 Databases

@ Internet » | & Desktop GIS

? Other » | @8 Navigation and Maps
#a Programming » | 5t Spatial Tools

K% sound & Video » | 73 Web Services

Q system Tools »| -] sample data
¥ Preferences » | & OSGeo Software Help

<>> 0 S G e 0 Live *’af::m N /---m§7

0% & s 125 O



http://www.archaeogeek.com/portable-gis.html
http://live.osgeo.org/en/index.html
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Preparando la sesion

e Planificar el proyecto SIG
- proyeccidony escala de trabajo
- fuente y disponibilidad de los datos
- metadatos...

e Sobre los archivos de proyectos de QGIS
- NO incluyen la informacion geografica

- enlazan con los archivos/registros de datos espaciales: mantienen las
relaciones entre los datos, las caracteristicas de visualizacion y el patron
para la impresion de mapas

ejercicio_0 - QGIS
Project Edit View Layer Settings Plugins Vector Raster Database Help

DEBRRRY OQLLANPPLAKALBRINR 6 K-8-EE I &0 [0-
RV /W V/BRR-ZT<0B60 “SULEAVLRFS

e e e 400 800/km
YReTVE&E-BADL I —
v V! . grandes ciudades g

V| ° 500577 -2000000

v/ © 2000000 - 4000000

v O 4000000 - 6000000

v (O) 6000000 - 8000000

v

v/ () 8000000 - 9904000
r -

)
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—
Organizacion de datos y archivos

e estructuraclara

e directorios sugeridos: - T~ GIS Project

o directorio raiz b ti Bkps
archivos de proyecto < (B Layers

o capas definitivo > [l Raster
raster, vectorial y otros D [ Tables

o pruebas temporal > [ Vector
organiz. por temas o modelos > [ Maps

o fuentes s0locopia < [ Sandbox

y > [ GPS Raw Data
o mapas e informes Jefinitivo > B Model
e usode programas de sincronizacion b [ Model2

o FreeFileSync por ejemplo > [ Sources



http://www.freefilesync.org/

Se acabo la teoria...
vamos a ponernos con la practica
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Ejercicio 1a - abrir proyecto

Introduccion alos SIG libres: QGIS 3

e Objetivo:
o Primeravision de QGIS para ver interactuar con el interfaz
e Procedimiento
o Abrir un proyecto: ejercicio_1.ggs
o Varias opciones

Project > Open file

Atajo de teclado --> Ctrl+O
Icono de abrir

Desde el navegador de archivos

Project Edit View Layer Settings Plugins Vector R
R New '
New from Template
= Open...
Open From
Open Recent
Close
& Save Ctrl+S
& Save As... Ctrl+Shift+S

Save To >

Properties... Ctrl+Shift+P
Snapping Options...

Import/Export
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Introduccion alos SIG libres: QGIS 3

Interfaz grafica de usuario de QGIS

e barrade menus

e barrade herramientas®

e tablade contenidoy panel vertical
e vistadel mapa

e barradeestado

> SE PUEDE PERSONALIZAR

mover, ocultar y modificar menus, barras, etc.

] ejercicio_0 - QGIS

Project Edit View Layer Settings Plugins Vector Raster Database Help

NEEBERERRY MeLL,ArRPPL LA EMEI
BV 28 P /B R-ZT<5 860 =€

Layers
¢ @ ® T &~ &0
randes ciudades
v/ ° 500577 -2000000
v/ O 2000000 - 4000000
v, O 4000000 - 6000000
vl () 6000000 - 8000000
v/ (_) 8000000 - 9904000
V! — Ffronteras
V| — coastline
v/ paises
v! i fondo NaturalEarth

Browser
QR2v®eo
» 7 Favorites
» [¥ Project Home
» [6] Home
» O/
» @ GeoPackage
» / SpatiaLite
@ Postals
P MssQL
DB2
» @ WMS/WMTS
» & XYZTiles
@ wcs
) WFS . ,
» O ows [~] ‘Western Sahara
| Q Type to locate (Ctrl+K) i| -985418,6334897 |9 2/1:18531333  ~ | @ r|100%
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Project Edit View Layer Settings Plugins Vector Raster Database Help

NoERBRRRY DL HPPRALARBRBIRC - -N-5-,5E 2 -

ROV AM 4 /B R Zaxs 060 "4EAITTTE & B ¥

Layers @ . < 00/} -
'L (K ;)fl ) Y ‘__cr' K &)
¢« 3OV &R A0 — ")

randes ciudades
V! ° 500577 -2000000
v/ O 2000000 - 4000000
v, O 4000000 - 6000000
v () 6000000 - 8000000
v () 8000000 - 9904000
—— fronteras
— coastline
v paises Y
V| ¥ fondo NaturalEarth

Browser @

LET®O

<7 Favorites |a

Project Home

[¢] Home

0o/

@ GeoPackage

/ SpatiaLite

@ postalis

P MssQL

DB2

> B WMS/WMTS

» & XYZTiles

@ wcs ‘
|

14
4
>
14
4
»

CCBY-SA 4.0‘- 2019 - M. Se\/].illa-céllejo
Proyecto realizado con QGIS 3.4 Madeira

@ WFS
» & OwWs

| Q Type to locate (Ctrl+K) l i| -985418,6334897 |

-  Western Sahara
118531333 |~ | @ r/100% 2] 3

00° 3| VI Render @ EpsG38s7 @




ejercicio_0 - QGIS
Project Edit View Layer Settings Plugins Vector Raster Database Help barra d e m ends

DEBRGRY U@L NP L 5LIE EE T -
MOV LM S /BT

ayers
< L@ :6;? ﬂa"ﬁt‘&tﬂ

randes ciudades
V! ° 500577 -2000000
v/ O 2000000 - 4000000
V| O 4000000 - 6000000
v () 6000000 - 8000000
K/i( ) 8000000 - 9904000

- fronteras

— coastline
paises

/| & fondo

33

<<

panel
vertical
de
Browser contenido
ciRAEA y archivos

' Favorites

[ Project Ha

[¢] Home

0o/

@ GeoPackage

/ SpatiaLite

@ Postais

P MssqQL

DB2

» @ WMS/WMTS

» & XYZTiles
& wcs —
) WFS ‘

: E [

| Q Type to locate (Ctrl+K) 1| -985418,6334897 | 1:18531333  ~ | @ r 100% [2] 2 [00° 2| VIRender @ EPsG3ssT @

v vV v v v Vv

Algeria

. Libya

barra de estado
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Barra de menus

eiercicio 0 - OGIS

Project Edlt View Layer gettmgsiPluglns Vector Raster gatabase uelp

= | ~ ~ —~ W N - — —— - — annnnens —_
\ w | .- New Map View Ctrl+M P; {8 Data Source Manager ctrl+L
New from Template » & New 3D Map View Ctrl+Shift+M Create Layer » Ja New GeoPackage Layer...
Open... Ctrl+0 ig‘ Pan Map Add Layer » |\ New Shapefile Layer...
Open From » % Pan Map to Selection Embed Layers and Groups... /7 New SpatiaLite Layer...
Open Recent » ¥ Zoom In Ctrl+Alt++ Add from Layer Definition File... # New Temporary Scratch Laye
Close = Zoom Out Ctrl+Alt+- % Copy Style
[ save Ctrlss @, Identify Features Ctrl+Shift+l
[ save As... Ctrl+Shift+S Measure »| 1 CopyLayer
save To 4 % Statistical Summary
13 Zoom Full Ctrl+Shift+F ~ Open Attribute Table F6
Properties... Ctrlsshiftsp 42 zoom to Layer # Jogole Bt
42 Zoom to Selection ctrl+J (5

Snapping Options...

' 4
Import/Export e
Save As Layer Definition File...
Decorations ['1 Remove Layer/Group ctrl+D
Preview Mode ] Duplicate Layer(s)
. Show Map Tips Set Scale Visibility of Layer(s)
1%, New Bookmark... ctrl+B Set CRS of Layer(s) Ctrl+shift+C

) New Print Layout... Ctrl+P
) New Report...
4 Layout Manager...

Layouts

Exit QGIS ctrl+Q

" show Bookmarks Ctrl+Shift+B Set Project CRS from Layer

¥ Refresh F5 Layer Properties...
Filter... Ctrl+F

@ Show All Layers Ctrl+Shift+u

barra de menus ~ Hide All Layers Ctrl+Shift+H . od

@2 Show in Overview

®; Show Selected Layers
oo Show Allin Overview

Proyecto | Editar | Vista | Capas | Opciones | Plugins | Vectorial | Raster|

Toolbars
Toggle Full Screen Mode F11
Toagle Panel Visibility Ctrl+Tab
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Barra de estado

e Informa sobre diversos aspectos del proyecto:
o Posicion

Escala

Representacion / Renderizado

Sistema de coordenadas

Opciones del proyecto

Registro/ Log

O O O O O

[¢] Home
0o/
@ GeoPackage
/ SpatialLite
@ pPostais
P MssqQL
DB2
> & WMS/WMTS
» & XYZTiles
@ wcs
) WFS
» O ows = Pr
i) -985418,6334897 |9 =z 1:18531333 ~ | @ r 100% ]:i 3 [0,0°

v v v v

Algeria 4 1(

barra de estado

| Q Type to locate (Ctrl+K) M v/ Render @ EpsG:3857 @
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Introduccion alos SIG libres: QGIS 3

Panel vertical y capas de contenido

e Visualizar paneles verticales

Vista > Paneles
Activarlo con botén derecho

Diferentes paneles

Navegador archivos/datos
Capas de contenido / Layers
Orden de visualizacion

de capas

mapa de situacion

GPS od
navegador archivos ™

Advanced Digitizing Panel
| Browser (2) Panel
v Browser Panel
GPS Information Panel
Layer Order Panel
| Layer Styling Panel
V| Layers Panel
| Log Messages Panel
| Overview Panel
| Spatial Bookmarks Panel
Statistics Panel
Tile Scale Panel
| Undo/Redo Panel
Toolbars
Advanced Digitizing Toolbar

pgp By @ W S S miiiey T UApEY | K S

Project Edit View Layer Settings Plugins Vector Raster D:

NeEBRBRRN O L L » ALK

RQVe AW V/B-R-Z T ¢
Tayers @jE3 @77
¥ @l © TV &> & O

randes ciudades

v, ° 500577 -2000000
vl © 2000000 - 4000000
v O 4000000 - 6000000
v O 6000000 - 8000000
! () 8000000 - 9904000
v — Fronteras
V| — coastline
v paises Y
v ¥ fondo NaturalEarth

BI'OWSEI' EIIES)
O2T7T®O6
» " Favorites ay
» [® Project Home
[6] Home
o/
@ GeoPackage
/ SpatiaLite
@ Postals
P MssQL
2 oB2
> B WMS/WMTS
» @ XYZTiles
@ wcs
@ WFS ;
» ) OWS =l

4
4
»
»

| Q Type to locate (Ctrl+K) 1| -985418,6334897 | ¥
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}D;EE@ﬁx

Barra de navegacion

Y pppldPP R M-

Navegar por la vista del mapa

o Mover, hacer zoom, vista completa...
Identificar objetos

o Previaseleccidon de capa a identificar
Seleccionar objetos

o Através dediferentes métodos
Ver tabla de atributos

Herramienta de medicion

Introduccion alos SIG libres: QGIS 3

©

i:\&vv[,ldllg 3y »

% Select Features by Radius

= Measure Line Ctrl+Shift+M

- Measure Area Ctrl+Shift+

# Measure Angle

grandes ciudades :: Features Total: 1063, Filtered:

1063, Selected: 0

J 2 8B o ¢ & a VB S D H B8 e
f SCALERANK NATSCALE LABELRANK FEATURECLA  NAME NAMEPAR = NAMEALT  DIFFASCII  NAMEASCII  ADMOCA*
22 4 50 5 Admin-1 ca... Annaba 0 Annaba 0,000000(¢
_23 3 110 5 Populated ... Oran Wahran 0 Oran 0,000000(
24 3 110 6 Admin-1 ca... Santa Cruz Santa Cruz ... 0 Santa Cruz 0,000000(
25 3 110 6 Admin-0 ca... LaPaz 0 LaPaz 1,000000(
26 4 50 5 Admin-1 ca... Constantine 0 Constantine = 0,000000(
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Cambio del sistema de coordenadas

e/ { CC BY-SA 4.0 - 2019 - M. Sevilla-Callejo
- Westerh Sahara Proyecto realizado con QGIS 3.4 Madeira

Q Type to locate (Ctrl+K) ‘ i| -985418,6334897 | ¥ 2/1:18531333 v | @@ r 100% ?:i 3 [00° % V/Rendef @ EPSG:3857

Project Properties | CRS

Project Coordinate Reference System (CRS)

% General

desde barra de estado o desde A —
No projection (or unknown/non-Earth projection,
menu de Opciones B Metadata Filter | &

Recently used coordinate reference systems

Coordinate Reference System Authority ID =
¥ Default Styles * Generated CRS (+proj=utm +zone=30 +ellps=GRS80 +uni... USER:100025
. d . Lisboa_Bessel_Bonne EPSG:102163
WGS 84 EPSG:4326
e activar/desactivar e B
-E Relations ED50 / UTM zoe 30N EPSG:23030
L4 WGS 84 / Pseudo-Mercator EPSG:3857
transformacion al vuelo R nc
. @ Matios Coordinate reference systems of the world Hide deprecated CRSs
@
t d d d Coordinate Reference System Authority ID -
‘ usa r S I S ema e COO r ena aS QGIS Server WGS 84 / Mercator 41 EPSG:3994
. WGS 84 / Mercator 41 (deprecated) EPSG:3752
WGS 84 / PDC Mercator EPSG:3832
d ete r m I n a d O WGS 84 / PDC Mercator (deprecated) EPSG:3349
WGS 84 / Pseudo-Mercator EPSG:3857

4 »

Selected CRS \WGS 84 / Pseudo-Mercator

Proj4: +proj=merc +a=6378137 +b=6378137 . el
+lat_ts=0.0 +lon_0=0.0 +x_0=0.0 +y_0=0 B
+k=1.0 +units=m +nadgrids=@null +wktext B
+no_defs S e

Extent: -180.00, -85.06, 180.00, 85.06 N %
v

Datum Transformations

&|[(=|(/

Source CRS Source datum transform Destination CRS Destination datum transform

P éHe(p VVApply | 7éganceir + OK




M. Sevilla-Callejo 2019/20

Opciones generales de QGIS

e Opciones del funcionamiento del
programa

e Modificando el interfaz: iconos,
tamano de letra, idioma...

e Otros

[»] | override system locale

R General v Application

J@' System Style (QGIS restart required)

& crs Ul Theme (QGIS restart required)

B Data sources Icon size

7 Font

L
Canvas &
L Legend

n Map Tools

Rendering
Timeout for timed messages or dialogs

Hide splash screen at startup

Use native color chooser dialogs

A colors Modeless data source manager dialog

&% Digitizing V' Check QGIS version at startup

m Layouts v Project files

@ GDAL Open project on launch Welcome Page ~

Variables

Options | General

Introduccion alos SIG libres: QGIS 3

*ejercici
Project Edit View Layer =4« Plugins Vector Raster Database

= =W NEN User Profiles "D ‘
D - @ 27 Style Manager... - p
B@V AR

Layers

/| @ Custom Projections...

', Keyboard Shortcuts...
« @l ® T & v & & [l = interface Customization...

. _grandes ciudades 3, Options...
v, ° 500577 - 2000068

Fusion v
default v

24 ~

|

(o) Qt default Size |11

'5s

[»]
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Ejercicio 1b - montar vista sencilla

e Objetivo
o Cargar y manipular capas para montar una vista sencilla con datos
vectoriales y raster.
o Replicar el proyecto del ejercicio 1a

e Procedimiento aseguir
o Cargar las capas de datos: linea de costa, fronteras, fondo...

o Manipular y navegar por la vista de mapa
o Incluir etiquetas
o Decorarlavista
o Cambiar proyeccion
36
(s N o]
. . [N NN
e Divertirse! B
LS
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QGIS Browser --> Browser Tab

e Navegador de archivos independiente
¥ BF [l [ B /% W i
— desaparecid en version 3.0 Browser Pane] 2 2] [0

— sepuede arrastrar y soltar archivo OR&YTHO

. Ve ¥V [ Project home
e Ahorapanel en el interfaz grafico ey
. . | maps
e Gestionar favoritos desde el panel > i sandbox
# ejercicio_0.qgs

e Explorador alternativo: NextGIS Manager > Bl Home

R » <7 Favourites
GitHub, NextGIS.ru >/
P> MssqQL
@ PostGIs
» / Spatialite

> () OWS
> @ wcs
> @ WFS
> @ WMS

QGIS Browser

& Refresh @ Manage WMS V; New Shapefile & Set layer CRS

header Param Metadata Preview Attributes

»> 1 Home

v < Favourites

v £ /home/shared/cursoQGIS16
v 2 project
v £ layers
v & NaturalEarth
v £ 10m_cultural

2 10m_admin_O ...
9 10m_admin_0_...
9 10m_admin 0 _...
2 10m_admin_O ...
29 10m admin 0 ...



https://github.com/nextgis/nextgismanager
http://nextgis.ru/en/nextgis-manager/
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Anadir capas...

B@V. AW

¥y J B g%

Introduccion alos SIG libres: QGIS 3

“wE@9E2%%% A B ¥

Eﬁ Browser

+ Vector
4 Raster
n‘f:‘ Mesh
4 Delimited Text
r‘% GeoPackage
i': SpatiaLite
+ PostgreSQL
+ MSSQL
082, pB2
m Virtual Layer
@ WMS/WMTS
‘E—; WCS
g WFS
’,‘f\;}_ ArcGIS Map Server
@)y ATCGIS Feature Server

*

» GeoNode

L e e

Data Source Manager | Browser

Browser
BRTHO
v Favorites

» [] /home/miguel/GISData
» [¥ Project Home

[6] Home

O/

@ GeoPackage

/ SpatialLite

@ postclis

P MssQL

2 pB2

@ WMS/WMTS

@ XYZTiles

& wcs

@ WFS

) ows

& ArcGisMapServer

& ArcGisFeatureServer

*i¢ GeoNode
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| Browser
Anadir capa vectorial Ve
A Raster
e Anadir capa vectorial - compatible con OGR 2 e
e Formatos mas usados , Delimited Text

. . 3 ‘
— SHP > ESRI Shapefile: varios archivos 4 SiEaRackagE
i':_ SpatialLite

* r r r
e *shp;componen rafi untos, lineas o poligonos
shp; componente grafico (p polig ) o

e *dbf; componente tematico (tablas) 4 MssQL

indi ¥ DB2
e “shx; indice de conexidn % DB2

. . .. . . m Virtual Layer
e *prj;informacioén del sist. de referencia de coordenadas

@ WMS/WMTS

— Cobertura ArcINFO: carpeta con varios archivos £ wes

- CSV > tabla separada por comas (incluye coordenadas) 4 WES
*{d ArcGIS Map Server

- GPX > Datos de GPS (waypoints, rutes, tracks)

;?;J* ArcGIS Feature Serve

» GeoNode



http://www.gdal.org/ogr_formats.html

Data Source Manager | Vector

. Browser
Vector

+ Raster

Source Type

e File Directory Database Prot«

L Encoding UTF-8
2 & Mesh

. Source
- Delimited Text

ﬁk e Vector Dataset(s)
i’i SpatialLite
+ PostgreSQL
¥ MssQL
D82, DB2
m Virtual Layer
'&fi}, WMS/WMTS
‘E;‘l WCS

,*WFS

’gk ArcGIS Map Server

@)l ATCGIS Feature Server

» GeoNode

| ©Help

¥ Browser
. g Vector
Raster

+

X1/
o Mesh

, Delimited Text

E:Q GeoPackage
ii SpatiaLite
+ PostgreSQL
+ MssQL
D82 pB2
m Virtual Layer
@ WMS/WMTS
‘E;‘I WCS

.’WFS

& ArcGIS Map Server

D

» GeoNode

ArcGIS Feature Server

Data Source Manager | Delimited Text

File name

Layer name | Encoding | UTF-8

v File Format

® CSV (comma separated values)
' Regular expression delimiter

Custom delimiters

» Record and Fields Options
v Geometry Definition
Point coordinates
e Well known text (WKT)
No geometry (attribute only table)
Geometry CRS

b Layer Settings
Sample Data

Please select an input file
©Help

Geometry field -

Geometry type | Detect v

EPSG:25830 - ETRS89 / UTM zor — 2

% Close
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Introduccion alos SIG libres: QGIS 3

Opciones de las capas vectoriales

% Zoom to Layer

2 Zoom to Selection

“2 Show in Overview
Show Feature Count
Copy Layer

L! Duplicate Layer
LL Remove Layer...

~ Open Attribute Table
/ Toggle Editing
Filter...

Set Layer Scale Visibility...

Set CRS >
Export >
Styles >

Properties...

>> botdn derecho sobre la capa:

e Zoom selectivo

e Establecer CRSdelacapa
Establecer CRS del proyecto desde
la capa

Propiedades

Editar

Exportar / Salvar como...
Copiar/Pegar estilo

Renombrar
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Propiedades de las capas vectoriales X

Sobre la capa botdon derecho > Propiedades
Punto, linea o poligono / CSV, GPX
Propiedades de representacion

Simbologia

Layer Properties - fronteras | Symbology

R =sig'c symool .
@ Information
s Simple line
. — Simple line
« Symbology -
€z Labels
., Diagrams ‘
B source Fields o LAY
Attributes Form Unit Millimeter G
Joins Opacity 0100.0% °
&1 Auxiliary Storage Color (.
& Actions .
* Width | 0.26000 8
@ Display
7 ;
4 Rendering o All Symbols - o
Variables ‘ 5
[ Metadata & & I
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Etiquetar las capas

e Seccion de etiquetado > seleccionar campo o etiqueta
e Cambiar propiedades de etiquetado

Layer Properties - paises | Labels

= Single labels v | &
7 Information Label with s« COUNTRY £
38 Source v Text Sample ,
% Symbology Lorem Ipsum
Labels G
B iarams Lorem Ipsum ®]:24935160 | Ky v
B source Fields =0 Text Placement
- : |22 Formattin "
Attributes Form ‘s Buffer © Offset from centroid _ Horizontal (slow)

Joins '@ Backgrou O Around centroid O Free (slow)
\'J Shadow

s'. Auxiliary Storage
m@ Actions

® Display

4 Rendering

' Using perimeter ' Using perimeter (curved)
# Renderin¢ cantroid

* visible polygon © whole polygon €
Ll Force point inside polygon

Quadrant | @ | @d | Gd | ],
Variables (abe] @be]

B/ Metadata CTRJRCERRCT

"™ Dependencies Offset X,Y | 0.0000 . 0.0000 €,
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Mas propiedades de las capas vectoriales

Varian segun sean

puntos, lineas o poligonos
— rampas de colores
- simbolos
- etc.
Representacion
- simbolo unico
— por categorias
- por intervalos
Editor de estilos
Copiar/pegar estilos
Importar/exportar estilos

Ver segun escala

Layer Properties - countries | Symbology

E = singc symbol

) Information

JQ\_\ Source

& Symbology

€= Labels

*, Diagrams

E Source Fields

Attributes Form
Joins

ﬂ Auxiliary Storage

O@ Actions

@ Display

& Rendering
Variables

B/ Metadata

™ Dependencies
Legend

QGIS Server

7] Digitizing

= M Fill
[T simple fill

G | | ¢ LAY

Unit Millimeter

Opacity
Color

A All Symbols

corners diagonal dotted gradient
plasma

B I e e

R e e e el o
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Opciones generales del proyecto
R

o Titulo del proyecto Project Edit View Layer Settings Plugins Vector
. . " New Ctrl+N ICHG) ;}
e Rutaalos archivos: relativa/absoluta New from Template La s
. = Open... Ctr+O as
e Sistema de coordenadas Open From N A
| Open Recent >
e Otros —
H Save Ctrl+S
2 Save As... Ctrl+Shift+S
Project Properties | General Save To A

v General Settings

Revert...
Project file /home/miguel/GISData/QGIS_unizar/ejercicio01

Properties... Ctrl+Shift+P
Snapping Options...

)Q General
B/ Metadata Project home

& CRS Project title

Import/Export >

1 72 New Print Layout... Ctrl+P
¥ Default Styles Selection color v Background color v 4 New Report...

B8 Data Sources Save paths e - 4 Layout Manager...

|

2] : Layouts >
@ Relations ) Avoid artifacts when project is rendered as map tiles (degrades perf

. Exit QGIS Ctrl+Q
VELELIES e v
v Measurements
U@ Macros Ellipsoid ——— ¥ gtopo30_cliped_iberia.ti
¥ QGIS Server (for distance and area calculations) ¥ NE2_HR_LC_SR_W.jpg
Q@ ejercicio_0 .

"
v

Semi-major 6378137.000 | SemiH
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Anadir “decoraciones” a la vista

e Anadir: Norte, escalay texto

t Edit View Layer Settings Plugins Vector Raster Database Web Processing Help (] Exportar como imagen
= f ‘< New Map View cr+M (1 [0 [ & @ @ v [ .
o v, BPantip P e (georeferenciada)
“ 7 & pan Map to Selection \
o ¥ “8.# zoomIn Ctrl+Alt++ =~
# Zoom Out Ctri+Alt+-
T ¢
—— @ dentify Features Ctrl+Shift+I
grande M 1
7 o o easure
s O o 2 Statistical Summary
? O 4052 z00m Full Ctrl+Shift+F
AON %9 Zoom to Layer

4 O 80 zoom to Selection Ctrl+

- fronte'l /d Zoom Last ‘ ’ (
B M /4 Zoom Next L o
.t y. to Native Resolution (100%) = | Slico o
: #~ L00mM ! S % oS SR - ORI ST P &l
F fando 418,6334897 |z 1:18531333 ~ | @ r|
T Decorations -
T & @ preview Mode > =5 Scale Bar...
& 00_f;" show Map Tips North Arrow...
z b.ct).u 0% New Bookmark... Ctrl+B s Copyright Label... ; : \,‘ Libya
citie | . ‘ '
& coa I* Show Bookmarks Ctrl+shift+B s Layout Extents... : | /
2 Refresh F5 P ot CC BY-SA 4.0 - 2019 - M. Sevilla-Callejo
Proyecto realizado con QGIS?{)A Madeira
¥ gtof » show All Layers Ctrl+Shift+U o ; =
° 2l :
. # NE2 _ \jige All Layers Ctrl+Shift+H 00 *| V/Render @ EPSG3857 @
Y ejercici

s 2 ShOW Selected Layers Wectern Gahara

T — . [r—— R—
e to loca ~ Hide Selected Layers ald 1:24935160 | @@ vagnifie  10¢
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Realidad espacial de una capa raster

Es una matriz de datos sobre una e Datos numeéricos
estructura X eY (longitud y latitud) o enteros, decimales, RGB...
e Datos nulos

o céldas sin datos
o Avecesseusa“-9999”

Celdas de una malla raster con sus Representando elementos espaciales
valores asociados (Olaya 2016) (raster tematico). Fig. de Olaya 2016



http://volaya.github.io/libro-sig/chapters/Tipos_datos.html
http://volaya.github.io/libro-sig/
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E Browser

Anadir capa raster (imagen) ecior

. Raster

e Anadir caparaster - compatible con GDAL

e Formatos mas usados
- GeoTIFF — *tif
- IMG de ERDAS Image — *img
— Grid de ArcINFO (dentro de una carpeta)

‘SV
o Mesh
. Delimited Text
t‘% GeoPackage
#4 SpatiaLite
& PostgresQL
- Estos archivos pueden estar acompanados de otros . MSSQL
archivos complementarios: *xml, *.rrd, *.aux 083, ps2
metadatos, georeferenciacion, piramides, ... WA virtual Layer

5 *ejercicio_0 - QGIS @ WMS/WMTS

Project Edit View Layer Settings Plugins Vector Raster Database Web Processing Help

NEBRRRY 0@l PPRAERlR &6 - Co Q%EE
%@V"ﬁ’;ﬁ -/ Bl T B 60 = 4EHIGYR %e&@&z A B

' KR ArcGIS Map Server

Layers @® &

¥ @l ® TV § 7 s S 0 250

e S @) ArcGIS Feature Serve
grandes ciudades Y Z ‘ NI
v — fronteras .
8 & - gtopo30 cliped iberia ; et BARGE b 5 ‘ + GeoNode
[ § R SO

2A0NNA


http://www.gdal.org/formats_list.html
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Propiedades de las capas raster (1)

e Raster tematicos, continuos o
imagenes
e Unabanda o varias bandas

v Band Rendering

@ Information Render type Singleband pseudocolor v

3 Source Band Band 1 (Gray)

& Symbology
l&@ Transparency

Min 0

» Min / Max Value Settings

B Histogram

Interpolation Linear

& Rendering
@& Pyramids
B/ Metadata

Color ramp

Label unit
suffix

Legend Colol Label

Value
QGIS Server 0 )
500 500
1000
1500
2000 2000
2500 .
3000

Introduccion alos SIG libres: QGIS 3

e Propiedades: Gris,
pseudocolor, mapa de colores
e Crear paletade colores

Layer Properties - gtopo30_cliped_iberia | Symbology

Max 3000
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Propiedades de capas raster (2)

Layer Properties - gtopo30_cliped_iberia | Histogram

e Visibilidad
. @ Information Raster Histogram
® T[ransparencia 3 Source 600
s L . ¥ Symbology 500
e Piramides :
i@ Transparency e
o H |St0gra ma [ Histogram §
& Rendering %300—
e Metadatos i Pyramids |
| Metadat ]
B/ Metadata e '
Legend .
I8 QGIS Server =
0 500 1000 1500 2000
Pixel Value
= Band 1

@ Prefs/Actions v

L ) Set min/max style for Band 1
Min 1
Max 3006

Help Style ~ App
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Trabajar con archivos Geopackage

e Usar formatos interoperables

o http://switchfromshapefile.org/

e Usarestandares OGC

e Geopackage: base de datos espacial: SQLite Espacial

e Arquitectura cliente-servidor en un mismo archivo

e Admite vectorial y raster
e Puede alojar proyectos de QGIS (versiéon 3.10)

e Salvar como... geopackage

o cadacapaesunatablade datos del gpck
o arrastray soltar en el explorador

o gestionar con DB Manager



http://switchfromshapefile.org/
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Sistema de coordenadas personalizado

Propiedades > CRS personalizado

>> incluir ED50 (ver nota)

a *ejercicio_0 - QGIS

Project Edit View Layer Settings Plugins Vector Raster Database Web

N BB @7  User Profiles 63 a8 I |
e ¢ Style Manager... P ,

W@V, /A B /- g i oo im

% Custom Projections...

M D ‘:‘5 (J_ (=] ':»,’l § E P

% Keyboard Shortcuts...

+proj=utm +zone=30 +ellps=intl
+nadgrids=~/PENR2009.gsb
+units=m +no_defs +wktext

Otros sistemas:

o Lambert
o Mollweide
o Orthographic

mas en
https://gitlab.com/msevilla00/...

Layers
« [ ® ¥ &, 7 = S
# O . grandes ciudades

~ — fronteras

2 B < atopo30 clived iberia
Custom Coordinate Reference System Definition

v Define

format for specifying a CRS.

Name Parameters

You can define your own custom Coordinate Reference System (CRS) here. The definition must conform to the proj4
| | g
| *Gener... +proj=longlat +ellps=kaula +no_defs =
* Gener... +proj=longlat +ellps=lerch +no_defs
\ * Gener... +proj=longlat +ellps=MERIT +no_defs !‘
* Gener... +proj=longlat +ellps=mprts +no_defs f
\ * Gener... +proj=longlat +ellps=new_intl +no_defs b
* Gener... +proj=longlat +ellps=NWL9D +no_defs =
\ * Gener... +proj=longlat +ellps=plessis +no_defs
* Gener... +proj=longlat +ellps=SEasia +no_defs e
\ * Gener... +proj=longlat +ellps=SGS85 +no_defs i
* Gener... +proj=longlat +ellps=sphere +no_defs ;
\ * Gener... +proj=longlat +ellps=walbeck +no_defs £
| * Gener +nrai=lanalat +ellne=WGSAN +nn defe o
Name ETRS89 / LAEA Europe - 0 long
+proj=laea +lat_0=52 +lon_0=0 +x_0=4321000 +y_0=3210000 +ellps=GRS80 =
Parameters +towgs84=0,0,0,0,0,0,0 +units=m +no_defs B E



https://gitlab.com/msevilla00/qgis_files/blob/master/CRS/reproyectar_ED50_a_ETRS89.md
https://gitlab.com/msevilla00/qgis_files/blob/master/CRS/reproyectar_ED50_a_ETRS89.md
https://gitlab.com/msevilla00/qgis_files/blob/master/CRS/reproyectar_ED50_a_ETRS89.md

M. Sevilla-Callejo 2019/20 Introduccién a los SIG libres: QGIS 3

Algunos atajos de teclado

e Mostrar panel de capas Ctrl+1
e Mostrar panel de explorador Ctrl+2
e Mostrar panel de simbologia F7

e Limpiar pantalla/Ocultar todos los paneles: Ctrl + Tab

e Anadir capa Ctrl+L
e Moverse por lavista Pulsar espacio
e Buscar enel mapa Ctrl+K
e Salvar proyecto Ctrl+S
e Salvar proyecto como... Ctrl + Shift +S

Mas atajos de QGIS 3.4 en https://north-road.com/qgis-3-0-shortcuts/



https://north-road.com/qgis-3-0-shortcuts/
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Ejercicio 1
Creacion de una vista simple en QGIS

Objetivos:

Primera vision de QGIS para ver interactuar con el interfaz
Cargar y manipular capas para montar una vista sencilla con datos
vectoriales y raster.

Entrega:
Archivo del proyecto (*.qgs o * qgz) y capas en formato GeoPackage

[Opcional] Documento escrito con breve descripcién del proceso seguido
para la consecucion del ejercicio.




